<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:fb="http://www.facebook.com/2008/fbml"
      xmlns:og="http://ogp.me/ns#"
      lang="en-us">
    <head>

    

    

      <script>
        var mp_global = {"mpuid": "d1ecbb61-d7c1-54b8-a361-fcc2fe72a5cf", "author": ["Joan Vannorsdall"], "instance": "blueridgecountry", "type": "article", "fb_app_id": "176964235771495", "section": "departments", "tag": ["May\/June 2022", "Travel", "Our Blue Ridge Towns"], "subsection": "our-blue-ridge-towns", "urlname": "travelers_rest_south_carolina"};
      </script>
      
      <script type="text/javascript">
(function(d) {
var config = {
  kitId: 'jwood@leisuremedia360.com',
  scriptTimeout: 3000},h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(
/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement(
"script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";
tk.src='//use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;
f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
})(document);
</script>
      <title>Travelers Rest, South Carolina: Don’t Miss the Swamp Rabbit Trail - Blue Ridge Country</title>
      <meta name="generator" content="Metro Publisher (www.metropublisher.com)" />
      <meta name="viewport" content="width=device-width, initial-scale=1" />
      <meta itemprop="name" id="publisher-name" content="Blue Ridge Country - Exploring the Mountains of the South" />
      
        
        
      
      <meta name="description" content="Once a pass-through, TR is now a come-to town."/>
      <meta name="keywords" content="Joan Vannorsdall,Travel,Our Blue Ridge Towns,May/June 2022"/>
      <link rel="manifest" href="/manifest.json">
      
      <meta name="thumbnail" content="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528&amp;w=1200"/>
      <link rel="canonical" href="https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/"/>

      <link href="https://blueridgecountry.com/api/rss/content.rss" rel="alternate" type="application/rss+xml" title="Travelers Rest, South Carolina: Don’t Miss the Swamp Rabbit Trail - Blue Ridge Country" />
      

      <link rel="stylesheet" type="text/css" href="https://d3t13abgv0q40.cloudfront.net/mp-public/css/theme-newsy.e416613fe3aa8a71e1623dc82111945f.css"/>
      <link rel="stylesheet" type="text/css" href="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/screen.css"/>
      
      <script src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/mp.fca4ef801c68995651f3d29bcf538738.js" async="true"></script>
      <script src="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/option.js"></script>

      <link rel="shortcut icon" href="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/BRCfavicon2.png"/>

      <!-- Google Analytics -->
<script>
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-4391637-2', 'auto');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<!-- End Google Analytics -->
      <script>

document.addEventListener('broadstreetLoaded', function () {
  broadstreet.setTargeting(mp_global);
  broadstreet.watch({
    "autoAttach": {},
    "autoAttachAndWatch": {},
    "domain": 'ad.broadstreetads.com',
    "keywords": [],
    "networkId": 6081,
    "selector": 'broadstreet-zone',
    "softKeywords": false,
    "uriKeywords": false,
    "useAltZone": function () { return false },
    "useZoneAliases": true
});



(function() {
  var resizeTimer;
  var windowwidth = window.innerWidth;
  function resizer() {
      broadstreet.refreshAll();
  }

  window.addEventListener("resize", function(){
      if (window.innerWidth != windowwidth) {
          windowwidth = window.innerWidth;
          clearTimeout(resizeTimer);
          resizeTimer = setTimeout(resizer, 250);
      }
  });
})();


});
</script>
<script src="https://cdn.broadstreetads.com/init-2.min.js" async></script>

      <meta property="og:image" content="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528&amp;w=1200"/><meta property="og:image:width" content="675"/><meta property="og:image:height" content="450"/><meta property="og:image" content="https://blueridgecountry.com/downloads/9662/download/Joe-Hilta.jpg?cb=90f960776a16f524359a05f2de5bb3fa&amp;w=1200"/><meta property="og:image:width" content="675"/><meta property="og:image:height" content="450"/><meta property="og:image" content="https://blueridgecountry.com/downloads/9663/download/10372340_396754313807374_2493693209545173456_n.jpg?cb=f0c4844a088f03df0f3da3c8f14ba7db&amp;w=1200"/><meta property="og:image:width" content="675"/><meta property="og:image:height" content="522"/><meta property="og:image" content="https://blueridgecountry.com/downloads/9664/download/AMPHITHEATER_1.jpg?cb=ac6751ef36bb3a2ea31ba55a10176983&amp;w=1200"/><meta property="og:image:width" content="675"/><meta property="og:image:height" content="328"/><meta property="og:image" content="https://blueridgecountry.com/downloads/9665/download/Bakery-and-Bistro.jpg?cb=69849be3487155b30d1365f4d5dbe849&amp;w=1200"/><meta property="og:image:width" content="675"/><meta property="og:image:height" content="450"/><meta property="og:url" content="https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/"/><meta property="og:title" content="Travelers Rest, South Carolina: Don’t Miss the Swamp Rabbit Trail"/><meta property="og:description" content="Once a pass-through, TR is now a come-to town."/><meta property="og:type" content="article"/><meta property="og:site_name" content="Blue Ridge Country"/><meta property="fb:app_id" content="176964235771495"/><meta name="twitter:card" content="summary"/><meta name="twitter:site" content="@brcmagazine"/><meta name="twitter:creator" content="@brcmagazine"/><meta name="twitter:image" content="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528&amp;amp;w=1200"/>
      <meta name="author" content="Joan Vannorsdall"/><meta property="article:author" content="https://blueridgecountry.com/topics/joan-vannorsdall/"/><meta property="article:tag" content="Travel"/><meta property="article:tag" content="Our Blue Ridge Towns"/><meta property="article:tag" content="May/June 2022"/><meta property="article:published_time" content="2022-05-25T13:27:43.654657"/>
      
      <script type="application/ld+json">
{"@context": "http://schema.org", "@graph": [{"@id": "https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/", "headline": "Travelers Rest, South Carolina: Don\u2019t Miss the Swamp Rabbit Trail", "author": {"@type": "Person", "name": "Joan Vannorsdall"}, "image": "https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528&w=675", "publisher": {"@type": "Organization", "logo": {"@type": "ImageObject", "url": "https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/BRC-Logo-2013-header2.jpg"}, "sameAs": "https://blueridgecountry.com/", "name": "Blue Ridge Country"}, "dateModified": "2022-05-25T13:27:43.654657", "url": "https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/", "datePublished": "2022-05-25T13:27:43.654657", "articleSection": "Our Blue Ridge Towns", "mainEntityOfPage": "https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/", "creator": "Joan Vannorsdall", "keywords": ["Travel", "Our Blue Ridge Towns", "May/June 2022"], "@type": "Article", "name": "Travelers Rest, South Carolina: Don\u2019t Miss the Swamp Rabbit Trail", "thumbnailUrl": "https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528&w=675"}]}
</script>

      
      <link rel="apple-touch-icon" href="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/BRC-PWA-192-192.jpg" />
      

      

      

      
      
      <!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/5209426.js"></script>
<!-- End of HubSpot Embed Code -->

<meta name="google-site-verification" content="Ci5bNcjI2ruTGiKmR_A7In6-WZDo6lTISz_1TCPrN8M" />

<script type="text/javascript">var switchTo5x=true;</script>
<script type="text/javascript">stLight.options({publisher: "ur-ca2294b-547b-4cf2-939e-100d607df9bb", doNotHash: false, doNotCopy: false, hashAddressBar: false});</script>

<meta name="facebook-domain-verification" content="0o9ev1oa7i4yj9dne8ovchaz83k3ve" />

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1009084099222104', {
em: 'insert_email_variable,'
});
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1009084099222104&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->



<script src ="https://up.pixel.ad/assets/up.js?um=1"></script>
<script type="text/javascript">
	cntrUpTag.track('cntrData', '429d882810de2141');
</script>


<!-- TransUnion Pixel -->
<img style='display:none' src='//di.rlcdn.com/406006.gif?pdata=partner%3Dtap293339%2Cdata%3Dtype%3Asite%24audience%3ASS_BlueRidgeCountry_ClientSite_Control'/>
<!-- End TransUnion Pixel -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.1&appId=176964235771495&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
        
        
        
        

        <script type="text/javascript">
          /* register service worker to enable PWA */
          if ('serviceWorker' in navigator) {
            window.addEventListener('load', function() {
              navigator.serviceWorker.register('/mp-service-worker.js').then(function(registration) {
                // Registration was successful
                console.log('ServiceWorker registration successful with scope: ', registration.scope);
              }, function(err) {
                // registration failed :(
                console.log('ServiceWorker registration failed: ', err);
              });
            });
          }
        </script>

        

      <meta id="worstRating" itemprop="worstRating" content="0" />
      <meta id="bestRating" itemprop="bestRating" content="5" />
      <meta name="theme-color" content="#8E5F43"/>
    </head>
  <body class="mp-type-article mp-sidebar">
      

    <div id="body">
    <a class="skip-to-main" href="#maincontent">Skip to main content</a>
    <broadstreet-zone zone-id="wallpaper_left"></broadstreet-zone>
    
      
        <div id="section_departments">
          <div id="subsection_our-blue-ridge-towns">
      <div id="page">




        <div id="top">
          <div id="topads">

            <div id="topad1">
              <broadstreet-zone zone-id="leaderboard_top"></broadstreet-zone>
            </div>

            <div id="topad2">
              <broadstreet-zone zone-id="house_top"></broadstreet-zone>
            </div>

          </div>
          
<svg style="display: none;">
  <style>.icon{fill:currentColor}</style>
  <symbol id="nav-icon" viewBox="0 0 170 170">
    <path fill="none" d="M0 0h170v170H0z"/>
    <path class="icon" d="M140 109H30v16h110v-16zm0-32H30v16h110V77zm0-32H30v16h110V45z"/>
  </symbol>
</svg>
<div id="logo">
  
  <div id="mp-search-bar">
    <form action="https://blueridgecountry.com/api/search.html">
      <input type="text" name="q" title="Enter Search Words" placeholder="Search..." />
      <button class="search submit" type="submit" name="sa">Search</button>
    </form>
  </div>
  <div class="logo">
  <!--div class="header_links" tal:condition="python: header_links or socialmedia_urls"-->
    <div class="header_links">
        
            <a href="https://blueridgecountry.com/business/contact-us">Contact Us</a>
        
            <a href="http://blueridgecountry.com/Subscribe">Subscribe</a>
        
            <a href="https://service.qfie.com/BRC/clsBRCNewOrdForm.asp?strAspReason=210&amp;PubCode=BRC&amp;TrackCode=WEBG2017&amp;TwoParty=true" target="_blank" rel="noopener">Gifts</a>
        
            <a href="http://blueridgecountry.com/renew">Renew</a>
        
            <a href="http://blueridgecountry.com/renew">Change Address</a>
        
            <a href="https://service.qfie.com/BRC/clsBRCLookup.asp" target="_blank" rel="noopener">Make Payment</a>
        
    </div>
    <div class="chicklets">
        Connect With Us
        <a href="http://www.facebook.com/blueridgecountry" class="chicklet facebook" target="_blank" rel="noopener">facebook</a>
        <a href="http://twitter.com/brcmagazine" class="chicklet twitter" target="_blank" rel="noopener">twitter</a>
        <a href="http://www.youtube.com/user/BlueRidgeCountryMag" class="chicklet youtube" target="_blank" rel="noopener">youtube</a>
        <a href="http://pinterest.com/brcmagazine/" class="chicklet pinterest" target="_blank" rel="noopener">pinterest</a>
        <a href="https://www.instagram.com/blueridgecountry/" class="chicklet instagram" target="_blank" rel="noopener">instagram</a>
    </div>
  <a rel="home" href="https://blueridgecountry.com" title="Blue Ridge Country"><img src="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/BRC-Logo-2013-header2.jpg" class="standard" alt="Blue Ridge Country" title="Blue Ridge Country" height="115" width="418" />
    <meta id="logo-url" itemprop="url" content="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/BRC-Logo-2013-header2.jpg" />
    <meta id="logo-width" itemprop="width" content="418" />
    <meta id="logo-height" itemprop="height" content="115" />
    <meta id="publisher-logo" itemprop="logo" itemscope="" itemtype="http://schema.org/ImageObject"
        itemref="logo-url logo-width logo-height" />
                                                                       <img src="https://blueridgecountry.com/api/design-f9ab40799178d6d55999c99fadc861a2/BRC-Logo-2013-header2.jpg" class="responsive" alt="Blue Ridge Country" title="Blue Ridge Country" /></a>
</div>

</div>

<nav id="topnav">
  <a href="#" class="pull"><svg><use xlink:href="#nav-icon" /></svg></a>
  
<ul class="mainnav">
  <li class="menu_section_start menu_section_home">
	<a href="/index.html">Home</a>
    
  </li>
  <li class="menu_section_newsstand">
	<a href="https://blueridgecountry.com/newsstand">Magazine<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_magazine">
        <a href="https://blueridgecountry.com/newsstand/magazine">Features</a>
      </li>
      <li class="menu_subsection_departments">
        <a href="https://blueridgecountry.com/departments">Departments</a>
      </li>
      <li class="menu_subsection_online__exclusives">
        <a href="https://blueridgecountry.com/blogging">Online Extras</a>
      </li>
      <li class="menu_subsection_contests">
        <a href="https://blueridgecountry.com/newsstand/online_exclusives/deals-free-giveaways">Contests</a>
      </li>
      <li class="menu_subsection_end menu_subsection_digital-edition">
        <a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">BRC+</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_brc-digital-edition">
	<a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">BRC+<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_what-is-brc-plus">
        <a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">Log In</a>
      </li>
      <li class="menu_subsection_view-digital-archive">
        <a href="https://read.nxtbook.com/leisuremedia360/brc_/index.html" target="_blank">View Digital Library</a>
      </li>
      <li class="menu_subsection_end menu_subsection_digi-faq">
        <a href="https://blueridgecountry.com/digital-FAQ">Frequently Asked Questions</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_blogging">
	<a href="https://blueridgecountry.com/blogging">Web Extras<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_behind-brc">
        <a href="https://blueridgecountry.com/blogging">Blogs</a>
      </li>
      <li class="menu_subsection_kurts-hikes">
        <a href="https://blueridgecountry.com/blogging/kurts-hikes">Kurt's Hikes</a>
      </li>
      <li class="menu_subsection_birds-of-the-blue-ridge-american-redstart">
        <a href="https://blueridgecountry.com/blogging/birds-of-the-blue-ridge-american-redstart">Birds of the Blue Ridge</a>
      </li>
      <li class="menu_subsection_wild-edibles">
        <a href="https://blueridgecountry.com/blogging/wild-edibles">Wild Edibles</a>
      </li>
      <li class="menu_subsection_end menu_subsection_mountain-recipes">
        <a href="https://blueridgecountry.com/blogging/mountain-recipes">Favorite Mountain Recipes</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_categories">
	<a href="/search/event/calendar/index.html">Events<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_calendar">
        <a href="https://blueridgecountry.com/search/event/calendar/#page=1">Calendar</a>
      </li>
      <li class="menu_subsection_end menu_subsection_submit-your-events">
        <a href="http://blueridgecountry.com/events/submit.html">Submit Your Events</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_travel">
	<a href="https://blueridgecountry.com/travel">Travel<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_travel">
        <a href="https://blueridgecountry.com/travel">Travel</a>
      </li>
      <li class="menu_subsection_fall">
        <a href="https://blueridgecountry.com/travel/fall">Fall Travel</a>
      </li>
      <li class="menu_subsection_end menu_subsection_guidebooks">
        <a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank">Free Travel Info</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_archive">
	<a href="https://blueridgecountry.com/archive">Archive<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_favorites">
        <a href="https://blueridgecountry.com/archive/favorites">Favorite Articles</a>
      </li>
      <li class="menu_subsection_end menu_subsection_digital-archives">
        <a href="https://read.nxtbook.com/leisuremedia360/brc_plus/index.html" target="_blank">BRC+ Subscriber Exclusives</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_end menu_section_free-travel-info">
	<a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank">Free Travel Info<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_free-guides">
        <a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank">Free Guides</a>
      </li>
      <li class="menu_subsection_end menu_subsection_parkway-guide">
        <a href="https://info.leisuremedia360.com/free-2020-2021-parkway-guide" target="_blank">Parkway Guide</a>
      </li>
    </ul>
  </li>
</ul>
<ul class="subnav">
  <li class="menu_subsection_start menu_subsection_flavors">
    <a href="https://blueridgecountry.com/departments/flavors">Food &amp; Flavors</a>
  </li>
  <li class="menu_subsection_from-the-editor">
    <a href="https://blueridgecountry.com/departments/from-the-editor">From The Editor</a>
  </li>
  <li class="menu_subsection_mountain-report">
    <a href="https://blueridgecountry.com/departments/mountain-report">Mountain Report</a>
  </li>
  <li class="menu_subsection_hikes">
    <a href="https://blueridgecountry.com/departments/hikes">The Good Walk</a>
  </li>
  <li class="menu_subsection_animals">
    <a href="https://blueridgecountry.com/departments/animals">Creature Feature</a>
  </li>
  <li class="menu_subsection_country-roads">
    <a href="https://blueridgecountry.com/departments/country-roads">Country Roads</a>
  </li>
  <li class="menu_subsection_mountain-garden">
    <a href="https://blueridgecountry.com/departments/mountain-garden">Singing in the Garden</a>
  </li>
  <li class="menu_subsection_guest-column">
    <a href="https://blueridgecountry.com/departments/guest-column">Guest Columnists</a>
  </li>
  <li class="menu_subsection_mill-creek-stories">
    <a href="https://blueridgecountry.com/departments/mill-creek-stories">Mill Creek Stories</a>
  </li>
  <li class="selected menu_subsection_end menu_subsection_our-blue-ridge-towns">
    <a href="https://blueridgecountry.com/departments/our-blue-ridge-towns">Our Blue Ridge Towns</a>
  </li>
</ul>


</nav>


        </div>
        <broadstreet-zone zone-id="leaderboard_nav"></broadstreet-zone>
        <div id="breadcrumbs"><a href="https://blueridgecountry.com">Home</a> <a href="https://blueridgecountry.com/departments">Departments</a> <a href="https://blueridgecountry.com/departments/our-blue-ridge-towns">Our Blue Ridge Towns</a> <a href="https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/">Travelers Rest, South Carolina: Don’t Miss the Swamp Rabbit Trail</a></div>
        <main id="maincontent" role="main" tabindex="-1">

  
<div id="pagetype_article" itemscope="" itemtype="http://schema.org/Article" itemid="https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/">

<span itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject">
    <meta id="content-image-url" itemprop="url" content="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528" />
    <meta id="content-image-width" itemprop="width" content="675" />
    <meta id="content-image-height" itemprop="height" content="450" />
</span>




  
  <article id="main">



<nav class="sectionpaging"><p class="prev"><a rel="prev" href="https://blueridgecountry.com/departments/our-blue-ridge-towns/greeneville-tn/">Greeneville, Tennessee: A Story on Every Building (and lots of Nature Nearby)</a></p>

</nav>

<header>
  
  <div id="title">
            <link itemprop="mainEntityOfPage" href="https://blueridgecountry.com/departments/our-blue-ridge-towns/travelers_rest_south_carolina/" />
            <meta itemprop="name" content="Travelers Rest, South Carolina: Don’t Miss the Swamp Rabbit Trail" />
            <meta itemprop="description" content="Once a pass-through, TR is now a come-to town." />
            <meta itemprop="publisher"
                  itemscope=""
                  itemtype="http://schema.org/Organization"
                  itemref="publisher-name publisher-logo" />
            <meta itemprop="dateModified" content="2022-05-25T13:27:43.654657" />
            <h1 itemprop="headline">Travelers Rest, South Carolina: Don’t Miss the Swamp Rabbit Trail</h1>
            
            
                <meta itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject"
                  itemref="content-image-url content-image-width content-image-height" />

                
            
          </div>
          
          <div id="pageinfos" class="pageinfos">
    <p class="author">by 
    <a href="https://blueridgecountry.com/topics/joan-vannorsdall/" rel="author" itemprop="author" itemscope="" itemtype="http://schema.org/Person">Joan Vannorsdall<meta itemprop="name" content="Joan Vannorsdall" /></a> </p>
    
    <time itemprop="datePublished" datetime="2022-05-25T13:27:43.654657">
    <p class="date">May 25, 2022</p>
    <p class="time">1:27 PM</p></time>
</div>

</header>


<aside class="tools">
    <div id="fb-top" data-show_like="True" data-show_share="True" data-like_url="https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/" data-size="small" data-layout="standard" data-action="like"></div>
    <div class="share">
      <span class='st_sharethis_large' displayText='ShareThis'></span>
<span class='st_facebook_large' displayText='Facebook'></span>
<span class='st_pinterest_large' displayText='Pinterest'></span>
<span class='st_twitter_large' displayText='Tweet'></span>
<span class='st_email_large' displayText='Email'></span>
    </div>
    <div class="share"><a class="RSS_link" href="https://blueridgecountry.com/departments/our-blue-ridge-towns/index.rss">RSS</a></div>
    <div class="share"><a class="print" href="#" onclick="javascript: window.print(); return false;" target="_self">Print</a></div>

</aside>



    
    

    <div id="content" class="carousel content no_js" data-transition="content" data-loop="false" itemprop="articleBody">


     <div>

    <p class="lead"><strong>Once a pass-through, TR is now a come-to town.</strong></p>&#13;
&#13;
<div id="media-carousel-6621" class="single media-carousel"><div class="media carousel no_js" data-nojump="true">    <div id="ms-slide-6621-0">    <span id="close-btn-6621-0" class="slideout-close-btn">×</span>        <div class="media-options">        <a class="open-slideshow group6621 hidden" id="ms_6621-0" data-image-url="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528" data-image-id="9661" data-slot-media-path="https://blueridgecountry.com/api/slot_media/15882/">Expand</a>      </div>        <div class="file">          <img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="PLACE_MARKER_25_BEST_2.jpg" data-src="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 675]" height="450" src="https://blueridgecountry.com/downloads/9661/download/PLACE_MARKER_25_BEST_2.jpg?cb=fdc61de3bccee196f236d52508171528" title="PLACE_MARKER_25_BEST_2.jpg" width="675">        <p class="credits">Courtesy City of Travelers Rest</p>            </div>        <div class="media-content">            <p>The welcome at TR goes well beyond the welcoming signage.</p>    </div>  </div>  </div></div><p>It’s a name that’s downright intriguing, Travelers Rest. Soothing, from a long time ago, promising comfort and rest from the journey.</p>&#13;
&#13;
<p>But here’s the thing. Travelers may rest…but they don’t stay. They’re heading somewhere else.</p>&#13;
&#13;
<p>That was, in fact, the stopover story of TR for a very long time, when Native Americans (Cherokee, Creek and Catawba nations) crossed over the Blue Ridge Escarpment; drovers from Tennessee and North Carolina headed for Low Country cattle markets; stage coaches and trains carried the wealthy away from coastal heat to western North Carolina retreats.</p>&#13;
&#13;
<p>Now, though, things are changing. TR is growing—its population grew 70% between 2010 and 2020, in part due to annexation of Furman University down the road. A few years back, TR was named one of the coolest small towns in America by Budget Travel in The Huffington Post, and one of the Best Southern Small Towns by USA Today. Its upscale restaurants along Main Street are filled by 5 pm weeknights. There’s a brewery and a creperie and a longstanding outdoors store that stocks more kayaks than any other storefront retailer in South Carolina.</p>&#13;
&#13;
<div id="media-carousel-6622" class="single media-carousel"><div class="media carousel no_js" data-nojump="true">    <div id="ms-slide-6622-0">    <span id="close-btn-6622-0" class="slideout-close-btn">×</span>        <div class="media-options">        <a class="open-slideshow group6622 hidden" id="ms_6622-0" data-image-url="https://blueridgecountry.com/downloads/9662/download/Joe-Hilta.jpg?cb=90f960776a16f524359a05f2de5bb3fa" data-image-id="9662" data-slot-media-path="https://blueridgecountry.com/api/slot_media/15883/">Expand</a>      </div>        <div class="file">          <img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Joe-Hilta.jpg" data-src="https://blueridgecountry.com/downloads/9662/download/Joe-Hilta.jpg?cb=90f960776a16f524359a05f2de5bb3fa&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 675]" height="450" src="https://blueridgecountry.com/downloads/9662/download/Joe-Hilta.jpg?cb=90f960776a16f524359a05f2de5bb3fa" title="Joe-Hilta.jpg" width="675">        <p class="credits">Courtesy City of Travelers Rest</p>            </div>        <div class="media-content">            <p>Aerial view of Travelers Rest highlights the beauty of the city and Paris Mountain on the horizon.</p>    </div>  </div>  </div></div><p>And among it all, impossible to overlook, are scores of walkers and bikers zigzagging through town.</p>&#13;
&#13;
<p>How does a small upstate town, like its many neighboring towns left to struggle in the wake of textile industry abandonment, come back to life so noticeably?</p>&#13;
&#13;
<p>Yes, there’s the strong group of TR natives, committed to telling their town’s story. (The TR Historical Society hosts regular storytelling sessions, and their headquarters at the end of Main Street is not to be missed, with a display case full of oral histories gathered by school children.)</p>&#13;
&#13;
<p>And there’s young, creative leadership growing new ideas from their deep community roots. (The under-40 mayor, Brandy Amidon, grew up in TR, went away to college, and has returned to help her town shape a vision.)</p>&#13;
&#13;
<p>And of course the beauty and outdoor recreation offered by what the Cherokee called the Blue Wall—the Blue Ridge rising up in the distance. (Nearby Paris Mountain is said to have a magnet in its core, drawing natives back home.)</p>&#13;
&#13;
<div id="media-carousel-6623" class="media-aside ">    <div class="gallery_slide single" id="media-thumb-6623-1" style="">            <div class="file group6623 " id="ms_6623-0" data-slot-media-path="/api/slot_media/15884/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="10372340_396754313807374_2493693209545173456_n.jpg" data-src="https://blueridgecountry.com/downloads/9663/download/10372340_396754313807374_2493693209545173456_n.jpg?cb=f0c4844a088f03df0f3da3c8f14ba7db&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 675]" height="464" src="https://blueridgecountry.com/downloads/9663/download/10372340_396754313807374_2493693209545173456_n.jpg?cb=f0c4844a088f03df0f3da3c8f14ba7db&amp;w=600" title="10372340_396754313807374_2493693209545173456_n.jpg" width="600"><div class="play slides_overlay"><!--need something here--></div><p class="credits">Courtesy City of Travelers Rest</p></div>            <div class="media-content">                <p>The farmers market on the Swamp Rabbit Trail is the largest independent market in South Carolina.</p>    </div></div></div><p>But what may well be the most interesting piece of Travelers Rest’s reinvention story is another wonderfully named location: The Swamp Rabbit Trail. (Long story short: the Swamp Rabbit was the nickname given to the Greenville + Northern Railway line that went through TR in the day—the ground was swampy and rough, making the rail lines “jumpy” like a swamp rabbit. And yes, swamp rabbits do exist!)</p>&#13;
&#13;
<p>The 22-mile rails-to-trails Swamp Rabbit runs from Greenville through Travelers Rest along the Reedy River.</p>&#13;
&#13;
<p>“TR was first in line to say yes to building the trail,” Amidon says. “The Swamp Rabbit’s been a major driver in the restoration of downtown. The trail was built for everyone.”</p>&#13;
&#13;
<p>In fact, through much of TR, the Swamp Rabbit and Main Street run nearly side-by-side. So if you want to stroll Main Street, put on your walking shoes and walk the length of TR’s section of the Swamp Rabbit. It’ll take you by Charlie’s Rustiques, located in an old Sinclair Gas Station with the green DINO brontosaurus still painted near the door. By the Whistle Stop Café (“Our fried green tomatoes are the best in the South!”). Past Sidewall Pizza Company, where thin-crust pizza go hand in glove with craft brews. A sushi place, and Chinese and Vietnamese eateries.</p>&#13;
&#13;
<p>And near the center of Main Street sits the beautiful Victorian Spring Park Inn, where, story has it, the owners used to greet the trains stopping just yards from the front door to help visitors with their luggage. Recently donated to the TR Historical Society by the original owner’s great-granddaughter, Nell Anderson Gibson, the house is listed on the National Register of Historic Places, and the surrounding 20 acres now has a conservation easement that assures it will not be developed. When the restoration is complete, the Spring Park Inn property will serve as a central gathering place for TR residents and visitors.</p>&#13;
&#13;
<p>And nearby the Inn, if fundraising is successful, there will soon be a statue of Travelers Rest Revolutionary War heroine, Dicey Langston, who lived most of her adult life in TR.</p>&#13;
&#13;
<p>“You can’t throw a rock without hitting a Dicey descendent,” Mayor Amidon says with a grin. (Langston gave birth to 22 children.) Called “the female Paul Revere,” Langston is best known for warning her brothers’ patriot encampment at Little Eden of an impending attack by the Tory renegade Bloody Scouts.</p>&#13;
&#13;
<p>It’s just plain fun to walk the Swamp Rabbit, used by visitors and residents, hard-core bikers and runners, kids and elders, dogs on leashes and babies in strollers. It’s beautiful evidence of “If you build it, they will come.”</p>&#13;
&#13;
<div id="media-carousel-6624" class="single media-carousel"><div class="media carousel no_js" data-nojump="true">    <div id="ms-slide-6624-0">    <span id="close-btn-6624-0" class="slideout-close-btn">×</span>        <div class="media-options">        <a class="open-slideshow group6624 hidden" id="ms_6624-0" data-image-url="https://blueridgecountry.com/downloads/9664/download/AMPHITHEATER_1.jpg?cb=ac6751ef36bb3a2ea31ba55a10176983" data-image-id="9664" data-slot-media-path="https://blueridgecountry.com/api/slot_media/15885/">Expand</a>      </div>        <div class="file">          <img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="AMPHITHEATER_1.jpg" data-src="https://blueridgecountry.com/downloads/9664/download/AMPHITHEATER_1.jpg?cb=ac6751ef36bb3a2ea31ba55a10176983&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 675]" height="328" src="https://blueridgecountry.com/downloads/9664/download/AMPHITHEATER_1.jpg?cb=ac6751ef36bb3a2ea31ba55a10176983" title="AMPHITHEATER_1.jpg" width="675">        <p class="credits">Courtesy City of Travelers Rest</p>            </div>        <div class="media-content">            <p>The amphitheater is also part of Trailblazer Park.</p>    </div>  </div>  </div></div><p>In fact, TR is bent on making sure that all of the city is bikeable and/or walkable. “We’ve been very intentional,” Amidon says. “Everything needs to be connected.”</p>&#13;
&#13;
<p>Just off the Swamp Rabbit, nearby Trailblazer Park is an unusual and beautiful blend of city recreation and government administration space. The park is home to the largest independent farmers market in South Carolina, and an amphitheater that hosts summer concerts and free movies.</p>&#13;
&#13;
<div id="media-carousel-6625" class="media-aside ">    <div class="gallery_slide single" id="media-thumb-6625-1" style="">            <div class="file group6625 " id="ms_6625-0" data-slot-media-path="/api/slot_media/15886/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Bakery-and-Bistro.jpg" data-src="https://blueridgecountry.com/downloads/9665/download/Bakery-and-Bistro.jpg?cb=69849be3487155b30d1365f4d5dbe849&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 675]" height="400" src="https://blueridgecountry.com/downloads/9665/download/Bakery-and-Bistro.jpg?cb=69849be3487155b30d1365f4d5dbe849&amp;w=600" title="Bakery-and-Bistro.jpg" width="600"><div class="play slides_overlay"><!--need something here--></div><p class="credits">Courtesy City of Travelers Rest</p></div>            <div class="media-content">                <p>Unique shops add to the experience of the small mountain city.</p>    </div></div></div><p>TR’s newest housing area—being built on a forty-acre site once home to a textile mill —will be easily walkable to the Swamp Rabbit and downtown.</p>&#13;
&#13;
<p>“We’ve worked with the family that owns the land to assure that there will be a lot of green space here in Pinestone,” Amidon says. “We’ll have apartments and single-family homes and some commercial space connected by walking trails.” If all goes as planned, an estimated 850 new residents will soon call TR home.</p>&#13;
&#13;
<p>True to its name, Travelers Rest, with its Swamp Rabbit trail connecting it to the growing city of Greenville on one end and the historic Geer Highway heading into North Carolina on the other, is still a place you can pass through. But it seems to me that it’s made a much stronger case for being a place to come to. </p>&#13;
&#13;
<hr>&#13;
<hr>&#13;
<hr>&#13;
<p><strong>The story above first appeared in our <a href="https://www.nxtbook.com/fx/archives/view.php?id=cf4c06a5049634d3e2172cde38565320&amp;nb=1" target="_blank">May / June 2022 issue</a>. For more like it </strong><strong><a href="https://blueridgecountry.com/subscribe">subscribe</a> today or </strong><strong><a href="https://blueridgecountry.com/PLUS">log in</a> with your </strong><strong><a href="https://blueridgecountry.com/PLUS">active BRC+ Membership</a>. Thank you for your support!</strong></p>&#13;
&#13;
<hr>&#13;
<hr>&#13;
<hr>

    
    

    </div>



    </div>

<div id="backlink_container" style="display:none"><a href="" id="backlink">Back to Search Results</a></div>
  


    
        
      
    



<aside class="tags">
<h4>Tags</h4>
                <a href="https://blueridgecountry.com/topics/travel/" rel="tag" >Travel</a>

                <a href="https://blueridgecountry.com/topics/blue-ridge-towns/" rel="tag" >Our Blue Ridge Towns</a>

                <a href="https://blueridgecountry.com/topics/may-june-2022/" rel="tag" >May/June 2022</a>

</aside>


<aside id="bottompageinfos" class="pageinfos">
    <p class="author">by 
    <a href="https://blueridgecountry.com/topics/joan-vannorsdall/" rel="author"
       >Joan Vannorsdall</a> </p>
    
    <time datetime="2022-05-25T13:27:43.654657">
    <p class="date">May 25, 2022</p>
    <p class="time">1:27 PM</p>
    </time>
</aside>

<aside class="tools">

    <div id="fb-bottom" data-show_like="True" data-like_url="https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/" data-show_share="True" data-size="small" data-layout="standard" data-action="like"></div>

    <div class="share">
      <span class='st_sharethis_large' displayText='ShareThis'></span>
<span class='st_facebook_large' displayText='Facebook'></span>
<span class='st_pinterest_large' displayText='Pinterest'></span>
<span class='st_twitter_large' displayText='Tweet'></span>
<span class='st_email_large' displayText='Email'></span>
    </div>

    <div class="share"><a class="RSS_link" href="https://blueridgecountry.com/departments/our-blue-ridge-towns/index.rss">RSS</a></div>
    <div class="share"><a class="print" href="#" onclick="javascript: window.print(); return false;" target="_self">Print</a></div>
</aside>

    

<aside id="related"></aside>


<div id="fb-comments"  data-comments_url="https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/" data-num_posts="10"
      data-order_by="time"></div>
  </article>

  

  <aside id="side">
    

        

    <div class="mp-imgteaser"><a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank" rel="noopener" title="Free Reader Info "><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Free Reader Info" data-src="https://blueridgecountry.com/downloads/7298/download/free%20reader%20info%20300x100.jpg?cb=deaa85563f45f990da1d84861c1c7e56&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" height="100" src="https://blueridgecountry.com/downloads/7298/download/free%20reader%20info%20300x100.jpg?cb=deaa85563f45f990da1d84861c1c7e56" title="Free Reader Info" width="300" /></a><p class="mp-credits"></p></div>
<div class="mp-html">
  <p style="text-align: center;"><strong>Want to learn more?</strong> Get free regional quick guides and travel brochures; info on retail, dining and attractions; moving information; details on upcoming events and festivals &ndash; and more!&nbsp;<span style="color: #0078c1;"><a href="https://info.leisuremedia360.com/brc-free-resources" style="color: #0078c1;">Click Here</a></span></p>

</div>
<div class="mp-sprocket-ajax-lazy" data-url="https://blueridgecountry.com/api/sprockets/ad_broadstreet/312/?context=section.190"></div><div class="mp-html">
  <p><span style="color:#ffffff;">_</span></p>

</div>
<div class="mp-imgteaser"><a href="https://read.nxtbook.com/leisuremedia360/brc_plus/index.html" target="_blank" rel="noopener" title="Click to login to our current issue!"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="BRC MJ 22 Cover" data-src="https://blueridgecountry.com/downloads/9604/download/BRC-MJ22-Cover.jpg?cb=b30b435804bb363c5340419e249811c5&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 413]" height="646" src="https://blueridgecountry.com/downloads/9604/download/BRC-MJ22-Cover.jpg?cb=b30b435804bb363c5340419e249811c5" title="BRC MJ 22 Cover" width="413" /></a><p class="mp-credits"></p></div>
<div class="mp-html">
  <h3 style="text-align: center;"><a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank"><img alt="BRC+ Logo Bar" src="/downloads/7818/download/BRC+-logo-bar.jpg" style="width: 100%;" /></a></h3>

<h3 style="text-align: center;"><strong>Subscriber Exclusives:</strong>&nbsp;</h3>

<p style="text-align: center;"><a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">Blue Ridge Country PLUS (BRC+)</a></p>

<p style="text-align: center;"><a href="https://read.nxtbook.com/leisuremedia360/brc_plus/index.html" target="_blank">Digital Edition Archives</a></p>

<p style="text-align: center;"><a href="https://apps.apple.com/us/app/blue-ridge-country-magazine/id653928703?ls=1">iOS App</a></p>

<p style="text-align: center;"><span style="color:#ffffff;">_</span></p>

</div>
<div class="mp-html">
  <p><span style="color:#ffffff;">_</span></p>

</div>
<div class="mp-sprocket-ajax-lazy" data-url="https://blueridgecountry.com/api/sprockets/ad_broadstreet/312/?context=section.190"></div><div class="mp-html">
  <p><span style="color:#ffffff;">_</span></p>

</div>
<div class="mp-html">
  <h3 style="text-align: center;"><strong>Sign Up For Our FREE E-Newsletters!</strong></h3>

<h3 style="text-align: center;"><span style="color:#ffffff;">_</span></h3>

<p style="text-align: center;"><!--[if lte IE 8]>
<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script>
<![endif]--><script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script><script>
  hbspt.forms.create({
	portalId: "5209426",
	formId: "520dca37-e1cd-4cc8-bff2-42ffb2fdf82e"
});
</script></p>

<p style="text-align: center;"></p>

</div>
<div class="mp-html">
  <p><span style="color:#ffffff;">_</span></p>

</div>
<div class="mp-imgteaser"><a href="https://service.qfie.com/BRC/clsBRCNewOrdForm.asp?strAspReason=210&amp;PubCode=BRC" target="_blank" rel="noopener" title="Subscribe today for as little as $10.95!"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="BRC House Subs 2018 - Med Rec" data-src="https://blueridgecountry.com/downloads/6718/download/300x250-2.jpg?cb=4a1d3ed2d66090f17c28766cbbc3f09d&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" height="250" src="https://blueridgecountry.com/downloads/6718/download/300x250-2.jpg?cb=4a1d3ed2d66090f17c28766cbbc3f09d" title="BRC House Subs 2018 - Med Rec" width="300" /></a><p class="mp-credits"></p></div>
<div class="mp-html">
  <p><span style="color:#ffffff;">_</span></p>

</div>
<div class="mp-sprocket-ajax-lazy" data-url="https://blueridgecountry.com/api/sprockets/cal/295/?context=section.190"></div>
    
  </aside>
  
  </div>


  


</main>

        <div id="bottom">
          <div id="bottomads">
            <broadstreet-zone zone-id="leaderboard_bottom"></broadstreet-zone>
          </div>
          
  
    <nav id="bottomnav">
      
<ul class="mainnav">
  <li class="menu_section_start menu_section_home">
	<a href="/index.html">Home</a>
    
  </li>
  <li class="menu_section_newsstand">
	<a href="https://blueridgecountry.com/newsstand">Magazine<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_magazine">
        <a href="https://blueridgecountry.com/newsstand/magazine">Features</a>
      </li>
      <li class="menu_subsection_departments">
        <a href="https://blueridgecountry.com/departments">Departments</a>
      </li>
      <li class="menu_subsection_online__exclusives">
        <a href="https://blueridgecountry.com/blogging">Online Extras</a>
      </li>
      <li class="menu_subsection_contests">
        <a href="https://blueridgecountry.com/newsstand/online_exclusives/deals-free-giveaways">Contests</a>
      </li>
      <li class="menu_subsection_end menu_subsection_digital-edition">
        <a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">BRC+</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_brc-digital-edition">
	<a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">BRC+<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_what-is-brc-plus">
        <a href="https://leisuremedia360.lpages.co/welcome-to-brc-plus/" target="_blank">Log In</a>
      </li>
      <li class="menu_subsection_view-digital-archive">
        <a href="https://read.nxtbook.com/leisuremedia360/brc_/index.html" target="_blank">View Digital Library</a>
      </li>
      <li class="menu_subsection_end menu_subsection_digi-faq">
        <a href="https://blueridgecountry.com/digital-FAQ">Frequently Asked Questions</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_blogging">
	<a href="https://blueridgecountry.com/blogging">Web Extras<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_behind-brc">
        <a href="https://blueridgecountry.com/blogging">Blogs</a>
      </li>
      <li class="menu_subsection_kurts-hikes">
        <a href="https://blueridgecountry.com/blogging/kurts-hikes">Kurt's Hikes</a>
      </li>
      <li class="menu_subsection_birds-of-the-blue-ridge-american-redstart">
        <a href="https://blueridgecountry.com/blogging/birds-of-the-blue-ridge-american-redstart">Birds of the Blue Ridge</a>
      </li>
      <li class="menu_subsection_wild-edibles">
        <a href="https://blueridgecountry.com/blogging/wild-edibles">Wild Edibles</a>
      </li>
      <li class="menu_subsection_end menu_subsection_mountain-recipes">
        <a href="https://blueridgecountry.com/blogging/mountain-recipes">Favorite Mountain Recipes</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_categories">
	<a href="/search/event/calendar/index.html">Events<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_calendar">
        <a href="https://blueridgecountry.com/search/event/calendar/#page=1">Calendar</a>
      </li>
      <li class="menu_subsection_end menu_subsection_submit-your-events">
        <a href="http://blueridgecountry.com/events/submit.html">Submit Your Events</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_travel">
	<a href="https://blueridgecountry.com/travel">Travel<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_travel">
        <a href="https://blueridgecountry.com/travel">Travel</a>
      </li>
      <li class="menu_subsection_fall">
        <a href="https://blueridgecountry.com/travel/fall">Fall Travel</a>
      </li>
      <li class="menu_subsection_end menu_subsection_guidebooks">
        <a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank">Free Travel Info</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_archive">
	<a href="https://blueridgecountry.com/archive">Archive<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_favorites">
        <a href="https://blueridgecountry.com/archive/favorites">Favorite Articles</a>
      </li>
      <li class="menu_subsection_end menu_subsection_digital-archives">
        <a href="https://read.nxtbook.com/leisuremedia360/brc_plus/index.html" target="_blank">BRC+ Subscriber Exclusives</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_end menu_section_free-travel-info">
	<a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank">Free Travel Info<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_free-guides">
        <a href="https://info.leisuremedia360.com/brc-free-resources" target="_blank">Free Guides</a>
      </li>
      <li class="menu_subsection_end menu_subsection_parkway-guide">
        <a href="https://info.leisuremedia360.com/free-2020-2021-parkway-guide" target="_blank">Parkway Guide</a>
      </li>
    </ul>
  </li>
</ul>
<ul class="subnav">
  <li class="menu_subsection_start menu_subsection_flavors">
    <a href="https://blueridgecountry.com/departments/flavors">Food &amp; Flavors</a>
  </li>
  <li class="menu_subsection_from-the-editor">
    <a href="https://blueridgecountry.com/departments/from-the-editor">From The Editor</a>
  </li>
  <li class="menu_subsection_mountain-report">
    <a href="https://blueridgecountry.com/departments/mountain-report">Mountain Report</a>
  </li>
  <li class="menu_subsection_hikes">
    <a href="https://blueridgecountry.com/departments/hikes">The Good Walk</a>
  </li>
  <li class="menu_subsection_animals">
    <a href="https://blueridgecountry.com/departments/animals">Creature Feature</a>
  </li>
  <li class="menu_subsection_country-roads">
    <a href="https://blueridgecountry.com/departments/country-roads">Country Roads</a>
  </li>
  <li class="menu_subsection_mountain-garden">
    <a href="https://blueridgecountry.com/departments/mountain-garden">Singing in the Garden</a>
  </li>
  <li class="menu_subsection_guest-column">
    <a href="https://blueridgecountry.com/departments/guest-column">Guest Columnists</a>
  </li>
  <li class="menu_subsection_mill-creek-stories">
    <a href="https://blueridgecountry.com/departments/mill-creek-stories">Mill Creek Stories</a>
  </li>
  <li class="selected menu_subsection_end menu_subsection_our-blue-ridge-towns">
    <a href="https://blueridgecountry.com/departments/our-blue-ridge-towns">Our Blue Ridge Towns</a>
  </li>
</ul>


    </nav>

    <div id="textnav">
      <ul>
  <li class="menu_section_start "
    >
    <a href="https://blueridgecountry.com/business/about">About Us</a>
  </li>
  <li class=""
    >
    <a href="https://blueridgecountry.com/business/contact-us">Contact Us</a>
  </li>
  <li class=""
    >
    <a href="http://blueridgecountry.com/Subscribe">Subscribe</a>
  </li>
  <li class=""
    >
    <a href="https://service.qfie.com/BRC/clsBRCNewOrdForm.asp?strAspReason=210&amp;PubCode=BRC&amp;TrackCode=WEBG2017&amp;TwoParty=true" target="_blank" rel="noopener">Gift Subscriptions</a>
  </li>
  <li class=""
    >
    <a href="http://blueridgecountry.com/renew">Renew Subscription</a>
  </li>
  <li class=""
    >
    <a href="http://blueridgecountry.com/renew">Change Address</a>
  </li>
  <li class=""
    >
    <a href="https://service.qfie.com/BRC/clsBRCLookup.asp" target="_blank" rel="noopener">Make Payment</a>
  </li>
  <li class=""
    >
    <a href="https://blueridgecountry.com/digital-FAQ">Digital Edition FAQ</a>
  </li>
  <li class=""
    >
    <a href="https://www.argifocus.com/Client/LeisurePCom/LM1/Custom/rsad.asp?t=10839&amp;search=" target="_blank" rel="noopener">Free Reader Info</a>
  </li>
  <li class=""
    >
    <a href="https://blueridgecountry.com/business/advertising-info">Advertising Information</a>
  </li>
  <li class=""
    >
    <a href="https://blueridgecountry.com/business/editorial-guidelines">Editorial Guidelines</a>
  </li>
  <li class="menu_section_end"
    >
    <a href="https://blueridgecountry.com/business/privacy.html">Privacy Statement</a>
  </li>
</ul>

    </div>
  
  

  <div id="copyright">
    <p>Copyright: LeisureMedia360, 1988</p>
  </div>

  <div id="mp_credits">
    Built with <a href="https://www.metropublisher.com" target="new">Metro Publisher&#8482;</a>
  </div>




        </div>

      </div>
      </div>
      </div>
      
    
    <broadstreet-zone zone-id="wallpaper_right"></broadstreet-zone>
    </div>
  
  
  <!-- Lightning Bolt Begins -->
  <script type="text/javascript" id="lightning_bolt" src="//cdn-akamai.mookie1.com/LB/LightningBolt.js"></script>
  <!-- Lightning Bolt Ends -->
  
    
  

    

  
    
      <script async defer src="//connect.facebook.net/en_US/sdk.js" ></script>
    
  

    

    <span id="mp-config" data-js="{&quot;_mp_page_content&quot;: {&quot;comments_url&quot;: &quot;https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/get_comments&quot;, &quot;media_support&quot;: {&quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slots&quot;: [{&quot;display_type&quot;: &quot;carousel&quot;, &quot;slot_ord&quot;: 0, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6621, &quot;slot_uuid&quot;: &quot;1f92a31f-081e-4ae3-8329-ce98f075c6ed&quot;}, {&quot;display_type&quot;: &quot;carousel&quot;, &quot;slot_ord&quot;: 1, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6622, &quot;slot_uuid&quot;: &quot;cd7f0d23-6cc5-41dc-883e-1025809f4d85&quot;}, {&quot;display_type&quot;: &quot;aside&quot;, &quot;slot_ord&quot;: 2, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6623, &quot;slot_uuid&quot;: &quot;4189a957-03ad-4a3a-b3fb-d8758574a6e9&quot;}, {&quot;display_type&quot;: &quot;carousel&quot;, &quot;slot_ord&quot;: 3, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6624, &quot;slot_uuid&quot;: &quot;c409925b-b1ed-4fa8-ffca-244eacbd7f05&quot;}, {&quot;display_type&quot;: &quot;aside&quot;, &quot;slot_ord&quot;: 4, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6625, &quot;slot_uuid&quot;: &quot;bae89972-0c18-4480-ee1c-aec794576dc8&quot;}]}, &quot;back_title&quot;: &quot;Return to \&quot;Travelers Rest, South Carolina: Don\u2019t Miss the Swamp Rabbit Trail\&quot;&quot;, &quot;media_gallery&quot;: {&quot;slideshowCurrent&quot;: &quot;{current} of {total}&quot;, &quot;slideshowStart&quot;: &quot;Start Slideshow&quot;, &quot;slideshowStop&quot;: &quot;Stop Slideshow&quot;, &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920]}, &quot;ctype&quot;: null, &quot;show_occ_paginator&quot;: false, &quot;google_api_key&quot;: &quot;AIzaSyBEfiI7S8NCyMrA8pbl-2F70VtqtKoQrG8&quot;, &quot;is_pro&quot;: true, &quot;tcomments&quot;: {&quot;content_uuid&quot;: &quot;b1d1af72-dc4e-11ec-83cd-12018e602a49&quot;, &quot;email_required&quot;: &quot;Email required&quot;, &quot;fb_login&quot;: &quot; or login with Facebook&quot;, &quot;comment_required&quot;: &quot;Comment required&quot;, &quot;subject_required&quot;: &quot;Subject required&quot;, &quot;post_moderated&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;fb_app_id&quot;: &quot;176964235771495&quot;, &quot;type_comment&quot;: &quot;Type your comment here...&quot;, &quot;email_invalid&quot;: &quot;Invalid email address&quot;, &quot;ugc_allow_comments&quot;: true, &quot;email&quot;: &quot;Email&quot;, &quot;view_more&quot;: &quot;View More&quot;, &quot;post_success&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;submit&quot;: &quot;Submit&quot;, &quot;info_text&quot;: &quot;All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;comments&quot;: &quot;Comments&quot;, &quot;subject&quot;: &quot;Type subject here...&quot;, &quot;rss_feed&quot;: &quot;Comment Feed&quot;, &quot;wrong_captchas&quot;: &quot;Wrong Captchas&quot;, &quot;type_captchas&quot;: &quot;Enter the word from the Image&quot;, &quot;name_required&quot;: &quot;Name required&quot;, &quot;fb_logout&quot;: &quot;Logout&quot;, &quot;chars_left&quot;: &quot;characters left&quot;, &quot;post_to_wall&quot;: &quot;Publish comment to your Wall&quot;, &quot;your_name&quot;: &quot;Your Name&quot;, &quot;ugc_email_for_comments&quot;: false}, &quot;osm_active&quot;: false, &quot;related_links_url&quot;: &quot;https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/get_related_links&quot;, &quot;show_dynamic_map&quot;: true}, &quot;_mp_cal_sprocket&quot;: true, &quot;_mp_sprocket_loader&quot;: true, &quot;_mp_&quot;: true, &quot;_mp_facebook_&quot;: true}"/><script async src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/cal_sprocket.3adf516967d6b4bd15190f62a8c2ff27.js" id="_mp_cal_sprocket"></script><script async src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/sprocket_loader.5111d2bb89749eda9702412555c5be17.js" id="_mp_sprocket_loader"></script><script async src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/page_content.5e44c68232579893c3919f99cfcdb26c.js" data-config="{&quot;comments_url&quot;: &quot;https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/get_comments&quot;, &quot;media_support&quot;: {&quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slots&quot;: [{&quot;display_type&quot;: &quot;carousel&quot;, &quot;slot_ord&quot;: 0, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6621, &quot;slot_uuid&quot;: &quot;1f92a31f-081e-4ae3-8329-ce98f075c6ed&quot;}, {&quot;display_type&quot;: &quot;carousel&quot;, &quot;slot_ord&quot;: 1, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6622, &quot;slot_uuid&quot;: &quot;cd7f0d23-6cc5-41dc-883e-1025809f4d85&quot;}, {&quot;display_type&quot;: &quot;aside&quot;, &quot;slot_ord&quot;: 2, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6623, &quot;slot_uuid&quot;: &quot;4189a957-03ad-4a3a-b3fb-d8758574a6e9&quot;}, {&quot;display_type&quot;: &quot;carousel&quot;, &quot;slot_ord&quot;: 3, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6624, &quot;slot_uuid&quot;: &quot;c409925b-b1ed-4fa8-ffca-244eacbd7f05&quot;}, {&quot;display_type&quot;: &quot;aside&quot;, &quot;slot_ord&quot;: 4, &quot;media_count&quot;: 1, &quot;slot_id&quot;: 6625, &quot;slot_uuid&quot;: &quot;bae89972-0c18-4480-ee1c-aec794576dc8&quot;}]}, &quot;back_title&quot;: &quot;Return to \&quot;Travelers Rest, South Carolina: Don\u2019t Miss the Swamp Rabbit Trail\&quot;&quot;, &quot;media_gallery&quot;: {&quot;slideshowCurrent&quot;: &quot;{current} of {total}&quot;, &quot;slideshowStart&quot;: &quot;Start Slideshow&quot;, &quot;slideshowStop&quot;: &quot;Stop Slideshow&quot;, &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920]}, &quot;ctype&quot;: null, &quot;show_occ_paginator&quot;: false, &quot;google_api_key&quot;: &quot;AIzaSyBEfiI7S8NCyMrA8pbl-2F70VtqtKoQrG8&quot;, &quot;is_pro&quot;: true, &quot;tcomments&quot;: {&quot;content_uuid&quot;: &quot;b1d1af72-dc4e-11ec-83cd-12018e602a49&quot;, &quot;email_required&quot;: &quot;Email required&quot;, &quot;fb_login&quot;: &quot; or login with Facebook&quot;, &quot;comment_required&quot;: &quot;Comment required&quot;, &quot;subject_required&quot;: &quot;Subject required&quot;, &quot;post_moderated&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;fb_app_id&quot;: &quot;176964235771495&quot;, &quot;type_comment&quot;: &quot;Type your comment here...&quot;, &quot;email_invalid&quot;: &quot;Invalid email address&quot;, &quot;ugc_allow_comments&quot;: true, &quot;email&quot;: &quot;Email&quot;, &quot;view_more&quot;: &quot;View More&quot;, &quot;post_success&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;submit&quot;: &quot;Submit&quot;, &quot;info_text&quot;: &quot;All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;comments&quot;: &quot;Comments&quot;, &quot;subject&quot;: &quot;Type subject here...&quot;, &quot;rss_feed&quot;: &quot;Comment Feed&quot;, &quot;wrong_captchas&quot;: &quot;Wrong Captchas&quot;, &quot;type_captchas&quot;: &quot;Enter the word from the Image&quot;, &quot;name_required&quot;: &quot;Name required&quot;, &quot;fb_logout&quot;: &quot;Logout&quot;, &quot;chars_left&quot;: &quot;characters left&quot;, &quot;post_to_wall&quot;: &quot;Publish comment to your Wall&quot;, &quot;your_name&quot;: &quot;Your Name&quot;, &quot;ugc_email_for_comments&quot;: false}, &quot;osm_active&quot;: false, &quot;related_links_url&quot;: &quot;https://blueridgecountry.com/api/content/b1d1af72-dc4e-11ec-83cd-12018e602a49/get_related_links&quot;, &quot;show_dynamic_map&quot;: true}" id="_mp_page_content"></script>

  </body>
</html>
